[[FrontPage]][[MIPS]]

-Creator CI20
-http://creatordev.io/ci20
-http://elinux.org/MIPS_Creator_CI20
-http://www.mikronauts.com/reviews/mips-creator-ci20-review-first-look/
-http://blog.techlab-xe.net/archives/3403


|Soc|Ingenic JZ4780 SoC|
|CPU|2 x MIPS-based XBurst 1.2GHz CPU|
|GPU|PowerVR SGX540 GPU|
|Memory|1GB DDR3 SDRAM|
|Storage|8GB NAND flash|
|Connectivity|1 x Ethernet port|
|~|802.11n|
|~|Bluetooth 4.0|
|Power Supply|5V DC input|

*イメージ焼き込み [#xa985530]
-イメージを [[CI20 Distros - eLinux.org>http://elinux.org/CI20_Distros]] からダウンロードしてくる。
-今回はDebian 8 2016-02-02 Beta にした
-[[CI20 Dev Zone - eLinux.org#NAND Flashing SD card>http://elinux.org/CI20_Dev_Zone#NAND_Flashing_SD_card]] に書いてあるとおりに、実行する
--母艦はWindowsを使用
--Win32DiskImager をダウンロード
--SDカードを用意。今回は32GB
--Win32DiskImager を管理者権限で起動
--Image File に nand_2016_06_02.img を指定
--Writeボタンを押す
--警告ボタンがあるが、OKを押して先にすすむ
--だいたい5分ぐらいでSDカードに書き込み終了
-SDカードをCI20本体に指す
-ジャンパピン3(JP3)を(defaultでは1,2をショートしているが)2,3をショートさせる
-ここで電源ケーブルを接続して起動する
-付属の電源ケーブルは微妙に接触が悪くて通電しなかった。奥まで差し込んで、ぐるぐる回してたら通電して起動した。
-通電した途端、LEDが赤く光る
-LEDが赤から青に変わる
-LEDが青に変わってから、10分程度放置(この間SDカード→Flashへの焼き込みが行われている)
-Flashへの書き込みが終わると、再度LEDが赤色にもどる
-この状態で電源を落とし、SDカードを抜いて、再度ジャンパピン3番で、1,2をショートさせる
-再度電源を入れると無事Debianが起動する

*初期設定 [#o8b460da]
-SSHでログインするために、WiFiに接続
-と思ったが、何かとWiFiだと不便なのでWiFiをスイッチオフにして有線接続
-以下SSHでログインして作業
--ログインアカウントはci20でパスワードもci20

*インストール [#yb5cd8bf]
-git と cmake をインストール
 sudo apt -y install git
-cmake のインストールだと何故かコケたので、cmake は apt でインストール
 sudo apt -y install cmake
-その他いつも使う奴
 sudo apt -y install vim
 sudo apt -y install vim pkg-config
-OpenCVのビデオ読み込みようにffmpegをインストール
 sudo apt-get install libavformat-dev libswscale-dev

*OpenCLをインストール [#cd6a9107]
-%%[[このページ>https://github.com/ehabhussein/Imagination-CI20-OpenCV-install]]&note{ci20-opencv:[[ehabhussein/Imagination-CI20-OpenCV-install: Mips CI20 openCV installation>https://github.com/ehabhussein/Imagination-CI20-OpenCV-install]]};を参考に、ocl-icd-opencl-dev ocl-icd-libopencl1 opencl-headersの3つをインストール%%
-%%sudo apt -y install ocl-icd-opencl-dev ocl-icd-libopencl1 opencl-headers%%
-参考ページ&note{ci20-opencv};には
> #No OpenCL support on the CI20

-と書かれていた。

トップ   編集 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 単語検索 最終更新   ヘルプ   最終更新のRSS